phosphor-mapper: remove deprecated path whitelist

The c++ mapper implements dbus service whitelists in place of path
based whitelists.  Drop support for path whitelists.

Change-Id: I02820bb136f7aa76fd9c782df648455bd9fb7536
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/recipes-phosphor/dbus/phosphor-legacy-namespace-mapper-config-native.bb b/recipes-phosphor/dbus/phosphor-legacy-namespace-mapper-config-native.bb
index 69c7779..2cb5b76 100644
--- a/recipes-phosphor/dbus/phosphor-legacy-namespace-mapper-config-native.bb
+++ b/recipes-phosphor/dbus/phosphor-legacy-namespace-mapper-config-native.bb
@@ -1,11 +1,10 @@
-SUMMARY="Add /org/openbmc namespace to phosphor-mapper"
-DESCRIPTION="Add the legacy /org/openbmc path namespace and \
-org.openbmc nterface prefix to the mapper watch list."
+SUMMARY="Add org.openbmc namespace to phosphor-mapper"
+DESCRIPTION="Add the legacy org.openbmc service namespace and \
+org.openbmc interface prefix to the mapper watch list."
 
 inherit phosphor-mapper
 inherit native
 inherit obmc-phosphor-license
 
-PHOSPHOR_MAPPER_NAMESPACE_append = " /org/openbmc"
 PHOSPHOR_MAPPER_SERVICE_append = " org.openbmc"
 PHOSPHOR_MAPPER_INTERFACE_append = " org.openbmc"