meta-phosphor: move all services to multi-user.target

Instead of obmc-standby.target, use multi-user.target.  This can be
accomplished by changing the definition of SYSTEMD_DEFAULT_TARGET first,
however, the explosive approach by removing that variable and
hard-coding multi-user.target provides a single-step.

Note: This patchset represents effectively the wholesale change of all
services in the meta-phosphor layer as well as the targets.  There are
other parts of OpenBMC that leverage the default variable.

Change-Id: I2b3b2274dd6b32d3832d6e768c26b2607f0ce71c
Signed-off-by: Patrick Venture <venture@google.com>
diff --git a/classes/obmc-phosphor-systemd.bbclass b/classes/obmc-phosphor-systemd.bbclass
index e892302..9b4419b 100644
--- a/classes/obmc-phosphor-systemd.bbclass
+++ b/classes/obmc-phosphor-systemd.bbclass
@@ -49,7 +49,7 @@
 inherit useradd
 
 _INSTALL_SD_UNITS=""
-SYSTEMD_DEFAULT_TARGET ?= "obmc-standby.target"
+SYSTEMD_DEFAULT_TARGET ?= "multi-user.target"
 envfiledir ?= "${sysconfdir}/default"
 
 # Big ugly hack to prevent useradd.bbclass post-parse sanity checker failure.