meta-phosphor: move all services to multi-user.target

Instead of obmc-standby.target, use multi-user.target.  This can be
accomplished by changing the definition of SYSTEMD_DEFAULT_TARGET first,
however, the explosive approach by removing that variable and
hard-coding multi-user.target provides a single-step.

Note: This patchset represents effectively the wholesale change of all
services in the meta-phosphor layer as well as the targets.  There are
other parts of OpenBMC that leverage the default variable.

Change-Id: I2b3b2274dd6b32d3832d6e768c26b2607f0ce71c
Signed-off-by: Patrick Venture <venture@google.com>
diff --git a/recipes-phosphor/chassis/obmc-op-control-power_git.bb b/recipes-phosphor/chassis/obmc-op-control-power_git.bb
index ab2a18e..8bae112 100644
--- a/recipes-phosphor/chassis/obmc-op-control-power_git.bb
+++ b/recipes-phosphor/chassis/obmc-op-control-power_git.bb
@@ -90,7 +90,7 @@
 
 # Force the standby target to run the chassis reset check target
 RESET_TMPL_CTRL = "obmc-chassis-powerreset@.target"
-SYSD_TGT = "${SYSTEMD_DEFAULT_TARGET}"
+SYSD_TGT = "multi-user.target"
 RESET_INSTFMT_CTRL = "obmc-chassis-powerreset@{0}.target"
 RESET_FMT_CTRL = "../${RESET_TMPL_CTRL}:${SYSD_TGT}.wants/${RESET_INSTFMT_CTRL}"
 SYSTEMD_LINK_${PN} += "${@compose_list_zip(d, 'RESET_FMT_CTRL', 'OBMC_CHASSIS_INSTANCES')}"