meta-phosphor: move all services to multi-user.target

Instead of obmc-standby.target, use multi-user.target.  This can be
accomplished by changing the definition of SYSTEMD_DEFAULT_TARGET first,
however, the explosive approach by removing that variable and
hard-coding multi-user.target provides a single-step.

Note: This patchset represents effectively the wholesale change of all
services in the meta-phosphor layer as well as the targets.  There are
other parts of OpenBMC that leverage the default variable.

Change-Id: I2b3b2274dd6b32d3832d6e768c26b2607f0ce71c
Signed-off-by: Patrick Venture <venture@google.com>
diff --git a/recipes-phosphor/leds/phosphor-led-manager_git.bb b/recipes-phosphor/leds/phosphor-led-manager_git.bb
index 3b3ac82..8689e06 100644
--- a/recipes-phosphor/leds/phosphor-led-manager_git.bb
+++ b/recipes-phosphor/leds/phosphor-led-manager_git.bb
@@ -38,7 +38,7 @@
 SYSTEMD_SERVICE_${PN}-ledmanager += "obmc-led-group-start@.service obmc-led-group-stop@.service"
 SYSTEMD_SERVICE_${PN}-faultmonitor += "obmc-fru-fault-monitor.service"
 
-SYSTEMD_LINK_${PN}-ledmanager += "../obmc-led-group-start@.service:${SYSTEMD_DEFAULT_TARGET}.wants/obmc-led-group-start@bmc_booted.service"
+SYSTEMD_LINK_${PN}-ledmanager += "../obmc-led-group-start@.service:multi-user.target.wants/obmc-led-group-start@bmc_booted.service"
 
 STATES = "start stop"
 TMPLFMT = "obmc-led-group-{0}@.service"