meta-phosphor: move all services to multi-user.target

Instead of obmc-standby.target, use multi-user.target.  This can be
accomplished by changing the definition of SYSTEMD_DEFAULT_TARGET first,
however, the explosive approach by removing that variable and
hard-coding multi-user.target provides a single-step.

Note: This patchset represents effectively the wholesale change of all
services in the meta-phosphor layer as well as the targets.  There are
other parts of OpenBMC that leverage the default variable.

Change-Id: I2b3b2274dd6b32d3832d6e768c26b2607f0ce71c
Signed-off-by: Patrick Venture <venture@google.com>
diff --git a/recipes-phosphor/state/phosphor-state-manager_git.bb b/recipes-phosphor/state/phosphor-state-manager_git.bb
index 5408b47..59c743a 100644
--- a/recipes-phosphor/state/phosphor-state-manager_git.bb
+++ b/recipes-phosphor/state/phosphor-state-manager_git.bb
@@ -87,14 +87,14 @@
 
 # Force the standby target to run the host reset check target
 RESET_TMPL_CTRL = "obmc-host-reset@.target"
-SYSD_TGT = "${SYSTEMD_DEFAULT_TARGET}"
+SYSD_TGT = "multi-user.target"
 RESET_INSTFMT_CTRL = "obmc-host-reset@{0}.target"
 RESET_FMT_CTRL = "../${RESET_TMPL_CTRL}:${SYSD_TGT}.wants/${RESET_INSTFMT_CTRL}"
 SYSTEMD_LINK_${PN}-host-check += "${@compose_list_zip(d, 'RESET_FMT_CTRL', 'OBMC_HOST_INSTANCES')}"
 
 TMPL = "phosphor-discover-system-state@.service"
 INSTFMT = "phosphor-discover-system-state@{0}.service"
-FMT = "../${TMPL}:${SYSTEMD_DEFAULT_TARGET}.wants/${INSTFMT}"
+FMT = "../${TMPL}:multi-user.target.wants/${INSTFMT}"
 SYSTEMD_LINK_${PN}-discover += "${@compose_list(d, 'FMT', 'OBMC_HOST_INSTANCES')}"
 
 # Force the shutdown target to run the chassis-poweroff target