phosphor-ipmi-flash: srcrev bump 4306f68bf4..09114c1c48
Patrick Venture (57):
Enable firmware transport mechanisms
firmware: implement canHandleBlob
rename: Rename firmware to blobid where appropriate
gitignore: Add test-driver
test: Add first unit-test to verify factory
main: handle error checking with handler creation
firmware: add active blob ids
firmware: implement stat command
test: fixup unit-test naming
tests: Add unit-tests for canHandleBlob
firmware: start implementing open
add image_handler interface for open
firmware: add handler for static layout
firmware: add write method
add data handler interface
firmware: move enum into class
set up data handler mechanism
firmware: invert conditions to reduce depth
tests: add unit-tests for opening
build: cleanup makefile whitespace
firmware: add active to canhandle blob list
firmware: start notion of a session
s/::bt/::ipmi/g to be more correct
firmware: set up hash handler
firmware: add a session lookup map
firmware: tie implementation of session into write
tests: cleanup test code
firmware: add read/write configuration methods
firmware: add global state for the process
firmware: prevent writing or opening during verification
style: s/FirmwareUpdateFlags/UpdateFlags/g
pci: continued implementation in P2A bridge handler
data handler: add open method
data handler: add close method
pci: add region parameter to constructor
static: add temporary filename for staging update
session: add per session state information
session: start tracking open state
firmware: add verification response enum
firmware: cleanup - cleaned up some documentation
firmware: return failure on attempt to open active files
bugfix: active blob id added on open failure
firmware: tie in call to data handler's open
firmware: enable fileOpen state
session: start tracking active path for session
firmware: start implementing close method
add createHandler method per phosphor-ipmi-blobs change
add lpc mapping interface and stubs
lpc_handler: drop-in call to mapWindow on writeMeta
lpc_handler: add note to copyFrom stub
firmware: start implementing deleteBlob
static_handler: implement basic version
lpc_handler also requires a BMC address for mapping
hash handler: implement file hash handler
static handler: transition to generic file handler
lpc: add missing headers
build: add lpc source files
Change-Id: Ifd0459231a6377db1c99bf13c33bec11dba4003d
Signed-off-by: Andrew Geissler <openbmcbump-github@yahoo.com>
diff --git a/recipes-phosphor/ipmi/phosphor-ipmi-flash_git.bb b/recipes-phosphor/ipmi/phosphor-ipmi-flash_git.bb
index b0767b5..eea9427 100644
--- a/recipes-phosphor/ipmi/phosphor-ipmi-flash_git.bb
+++ b/recipes-phosphor/ipmi/phosphor-ipmi-flash_git.bb
@@ -16,7 +16,7 @@
S = "${WORKDIR}/git"
SRC_URI = "git://github.com/openbmc/phosphor-ipmi-flash"
-SRCREV = "4306f68bf44ee0487422bf75adb6bc2f8c1ea26c"
+SRCREV = "09114c1c48041376087f4a1837c044e4a9e2b411"
FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
FILES_${PN}_append = " ${libdir}/blob-ipmid/lib*${SOLIBS}"