phosphor-ipmi-host.bb: bump version

Fix dependency between whitelists and ipmi-host by adding an
explicit recipe-task dependency.

Resolves openbmc/openbmc#1197.

Change-Id: Ic33fa3e9b3519935500c718f203b989b6c423684
Signed-off-by: Tom Joseph <tomjoseph@in.ibm.com>
Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
diff --git a/common/recipes-phosphor/packagegroups/packagegroup-obmc-ipmid-providers.bb b/common/recipes-phosphor/packagegroups/packagegroup-obmc-ipmid-providers.bb
index 476ad50..375e386 100644
--- a/common/recipes-phosphor/packagegroups/packagegroup-obmc-ipmid-providers.bb
+++ b/common/recipes-phosphor/packagegroups/packagegroup-obmc-ipmid-providers.bb
@@ -15,4 +15,16 @@
 WHITELIST_FORMAT = "{0}-whitelist-native"
 OBMC_IPMID_WHITELISTS = "${@compose_list(d, 'WHITELIST_FORMAT', 'OBMC_IPMID_PROVIDERS')}"
 
-DEPENDS_append = "${OBMC_IPMID_WHITELISTS}"
\ No newline at end of file
+DEPENDS_append = "${OBMC_IPMID_WHITELISTS}"
+
+# Normally the dependency is between do_configure and
+# DEPENDS:do_populate_sysroot, but when a package is in the SSTATE cache the
+# do_configure step is not re-ran. The do_populate_sysroot tasks can themselves
+# be performed in parallel by bitbake.
+# Since the do_populate_sysroot task of this recipe doesn't provide the
+# whitelists itself, we need an explicit dependency on the whitelist's
+# do_populate_sysroot task so that the whitelists are present in time for an
+# application that needs them to be do_configured.
+
+WHITELIST_TASK_FORMAT = "{0}:do_populate_sysroot"
+do_populate_sysroot[depends] = "${@compose_list(d, 'WHITELIST_TASK_FORMAT', 'OBMC_IPMID_WHITELISTS')}"