Remove S and SRC_URI from python daemon class

Initially this could be done in one place but as
sources move to git repositories this can't be done
in a generic manner.

Adapted existing recipes to this class change.
diff --git a/common/recipes-phosphor/obmc-phosphor-sys/obmc-phosphor-sysd.bb b/common/recipes-phosphor/obmc-phosphor-sys/obmc-phosphor-sysd.bb
index 3dc9a64..bcb5d32 100644
--- a/common/recipes-phosphor/obmc-phosphor-sys/obmc-phosphor-sysd.bb
+++ b/common/recipes-phosphor/obmc-phosphor-sys/obmc-phosphor-sysd.bb
@@ -4,3 +4,6 @@
 
 inherit obmc-phosphor-system-mgmt
 inherit obmc-phosphor-pydbus-service
+
+S = "${WORKDIR}"
+SRC_URI += "file://${PN}.py"