noverify-bmc-update: Add definition

This will be used by some platforms by default when enabling
phosphor-ipmi-flash so that the BMC image can be updated without any
signature verification checks in place.

Change-Id: I10ed4551120a7f17e67c0e8bc7090c6a8d4ce5ea
Signed-off-by: William A. Kennington III <wak@google.com>
diff --git a/recipes-phosphor/flash/noverify-bmc-update.bb b/recipes-phosphor/flash/noverify-bmc-update.bb
new file mode 100644
index 0000000..fb1480f
--- /dev/null
+++ b/recipes-phosphor/flash/noverify-bmc-update.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "phosphor-ipmi-flash config to update without verifying the image"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+
+inherit systemd
+
+SRC_URI += "file://noverify-bmc-verify.service"
+SRC_URI += "file://config-bmc.json"
+
+SYSTEMD_SERVICE_${PN} += "noverify-bmc-verify.service"
+FILES_${PN} += "${datadir}/phosphor-ipmi-flash/config-bmc.json"
+
+do_install() {
+  install -d ${D}${datadir}/phosphor-ipmi-flash
+  install -m 0644 ${WORKDIR}/config-bmc.json ${D}${datadir}/phosphor-ipmi-flash
+
+  install -d ${D}${systemd_system_unitdir}
+  install -m 0644 ${WORKDIR}/noverify-bmc-verify.service ${D}${systemd_system_unitdir}
+}