python-mako: remove mako-render from native recipe

Both python-mako and python3-mako attempt to install an executable into
/usr/bin/mako-render.  Neither of these are used by anything in openbmc.

Delete the executable for python-mako-native to avoid the collision.
Once we are done with python2 this can be deleted.

Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
Change-Id: I2b7ee4c8406636805e0f6d1c9951e2624d5b30be
diff --git a/recipes-devtools/python/python-mako_%.bbappend b/recipes-devtools/python/python-mako_%.bbappend
new file mode 100644
index 0000000..020bdd6
--- /dev/null
+++ b/recipes-devtools/python/python-mako_%.bbappend
@@ -0,0 +1,12 @@
+# python-mako installs /usr/bin/mako-render for both python2 and python3,
+# which causes a bitbake QA failure.  Remove it from installation for the
+# native target to avoid the collision.
+#
+# We don't currently use this as a target package and if we did, we shouldn't
+# install both python2 and python3 variants.
+#
+# Once we are done with python2, we can delete this.
+
+do_install_append_class-native() {
+    rm ${D}${bindir}/mako-render
+}