Fix YAML overriding.

bitbake tasks use python3, under which filter() returns a filter object
which doesn't enumerate as list. As a result none of the overriding YAMLs
takes effect. Use list expansion instead.

Discussion for context:
https://lists.ozlabs.org/pipermail/openbmc/2017-October/009521.html

Fixes openbmc/openbmc#2469.

Change-Id: I37cc7fc14b6f91c4eb1fb199d7cff52d93c9ad2a
Signed-off-by: Kun Yi <kunyi@google.com>
diff --git a/common/recipes-phosphor/settings/phosphor-settings.bb b/common/recipes-phosphor/settings/phosphor-settings.bb
index 191a389..8e94d8f 100644
--- a/common/recipes-phosphor/settings/phosphor-settings.bb
+++ b/common/recipes-phosphor/settings/phosphor-settings.bb
@@ -36,7 +36,7 @@
     cmd.append(os.path.join(d.getVar('S', True), 'settings.yaml'))
 
     fetch = bb.fetch2.Fetch([], d)
-    override_urls = filter(lambda f: f.endswith('.override.yml'), fetch.urls)
+    override_urls = [url for url in fetch.urls if url.endswith('.override.yml')]
     for url in override_urls:
         bb.debug(2, 'Overriding with source: ' + url)
         local_base = os.path.basename(fetch.localpath(url))