python-*: use pypi class

Cleanup the various python-* recipes which download from pypi. The
biggest change is to "inherit pypi" which should result in us always
using current pypi best practices. This will for example ensure we are
using https and not http.

Change-Id: I3e818284efb8094e64b004af22781c8a3fcb89b3
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/common/recipes-devtools/python/python-bottle_0.12.13.bb b/common/recipes-devtools/python/python-bottle_0.12.13.bb
index 590a3eb..08d84ff 100644
--- a/common/recipes-devtools/python/python-bottle_0.12.13.bb
+++ b/common/recipes-devtools/python/python-bottle_0.12.13.bb
@@ -1,5 +1,10 @@
-SRCNAME = "bottle"
-SRC_URI = "https://pypi.python.org/packages/bd/99/04dc59ced52a8261ee0f965a8968717a255ea84a36013e527944dbf3468c/${SRCNAME}-${PV}.tar.gz;name=tarball file://LICENSE file://json-format.patch"
-SRC_URI[tarball.sha256sum] = "39b751aee0b167be8dffb63ca81b735bbf1dd0905b3bc42761efedee8f123355"
-SRC_URI[tarball.md5sum] = "d2fe1b48c1d49217e78bf326b1cad437"
+SRC_URI[sha256sum] = "39b751aee0b167be8dffb63ca81b735bbf1dd0905b3bc42761efedee8f123355"
+SRC_URI[md5sum] = "d2fe1b48c1d49217e78bf326b1cad437"
+
+# There is no license on pypi.  See:
+# https://github.com/bottlepy/bottle/commit/55a505b3a54bb7de23e9554cb8ce7f8e160c31a0
+SRC_URI += "file://LICENSE"
+
+SRC_URI += "file://json-format.patch"
+
 require python-bottle.inc