python-*: use pypi class

Cleanup the various python-* recipes which download from pypi. The
biggest change is to "inherit pypi" which should result in us always
using current pypi best practices. This will for example ensure we are
using https and not http.

Change-Id: I3e818284efb8094e64b004af22781c8a3fcb89b3
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/common/recipes-devtools/python/python-gevent-websocket_0.10.1.bb b/common/recipes-devtools/python/python-gevent-websocket_0.10.1.bb
index 930ec3a..8ac2a89 100644
--- a/common/recipes-devtools/python/python-gevent-websocket_0.10.1.bb
+++ b/common/recipes-devtools/python/python-gevent-websocket_0.10.1.bb
@@ -11,12 +11,7 @@
 
 RDEPENDS_${PN} = "python-gevent"
 
-SRCNAME = "gevent-websocket"
-
-SRC_URI = "https://pypi.python.org/packages/98/d2/6fa19239ff1ab072af40ebf339acd91fb97f34617c2ee625b8e34bf42393/gevent-websocket-${PV}.tar.gz"
 SRC_URI[md5sum] = "e095bf3358175489a956949c1b4de9ff"
 SRC_URI[sha256sum] = "7eaef32968290c9121f7c35b973e2cc302ffb076d018c9068d2f5ca8b2d85fb0"
 
-S = "${WORKDIR}/${SRCNAME}-${PV}"
-
-inherit setuptools
+inherit setuptools pypi