Add OPENBMC_TARGET_MACHINE to /etc/os-release

This adds a new OS identification parameter (OPENBMC_TARGET_MACHINE) to
the /etc/os-release file in the generated OpenBMC image to indicate the
kind of device the OpenBMC image is targeted to control.
This is needed to be able to track the image back to its source code: the
distro and version indicate the exact source code that was used, and the
target machine says which Bitbake layer configuration within that source
was used.

Note the target machine name is typically set in the
openbmc/meta-*/meta-MACHINE/conf/local.conf.sample file.
(This is where TEMPLATECONF points to.)

The "uname" command options -m (machine) and -i (hardware platform) will
continue to refer to the BMC and not its target machine.

Tested: On the build system, `cat $IMAGE_ROOTFS/etc/os-release` shows
        the correct value.

Change-Id: I4b38ee882c8a7b04ade5b96d3e3a91d63309fcff
Signed-off-by: Joseph Reynolds <jrey@us.ibm.com>
diff --git a/recipes-core/os-release/os-release.bbappend b/recipes-core/os-release/os-release.bbappend
index 77249fc..c010146 100644
--- a/recipes-core/os-release/os-release.bbappend
+++ b/recipes-core/os-release/os-release.bbappend
@@ -24,9 +24,13 @@
     build_id = run_git(d, 'describe --abbrev=0')
     if build_id:
         d.setVar('BUILD_ID', build_id)
+
+    target_machine = d.getVar('MACHINE', True)
+    if target_machine:
+        d.setVar('OPENBMC_TARGET_MACHINE', target_machine)
 }
 
-OS_RELEASE_FIELDS_append = " BUILD_ID"
+OS_RELEASE_FIELDS_append = " BUILD_ID OPENBMC_TARGET_MACHINE"
 
 # Ensure the git commands run every time bitbake is invoked.
 BB_DONT_CACHE = "1"