stdplus: Add package

Ideally this would be using meson but our current version 0.47.2 is not
new enough to support that yet.

Change-Id: I10363557d23eba071b42199115897d0a6c4e9797
Signed-off-by: William A. Kennington III <wak@google.com>
diff --git a/recipes-extended/stdplus/stdplus_git.bb b/recipes-extended/stdplus/stdplus_git.bb
new file mode 100644
index 0000000..4b5db3c
--- /dev/null
+++ b/recipes-extended/stdplus/stdplus_git.bb
@@ -0,0 +1,23 @@
+SUMMARY = "Common C++ functions"
+DESCRIPTION = "Common C++ functions."
+HOMEPAGE = "http://github.com/openbmc/stdplus"
+PR = "r1"
+PV = "0.1+git${SRCPV}"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
+
+inherit autotools pkgconfig
+
+DEPENDS += " \
+        autoconf-archive-native \
+        "
+
+EXTRA_OECONF_append += " \
+        --disable-examples \
+        --disable-tests \
+        "
+
+SRC_URI += "git://github.com/openbmc/stdplus"
+SRCREV = "15982f6c0a252bc3642efb2df5d3c209e535c4fa"
+
+S = "${WORKDIR}/git"