ipmi-whitelist: fix compile issue

ipmi-whitelists were not working correctly when restored from sstate
due to incorrect path locations in the bbclass.  Files being installed
with the do_install step were not associated with the package because
they were placed in the wrong directory.  By placing in the right
directory, they are placed into the sstate file and restored correctly.

The files were also installed into /etc and move to /usr/share.  This
matches what is being done for the mrw files (see
phosphor-ipmi-fru.bbclass for example).

Change-Id: I1881d383d4d9d7d3098411fa83c85e49c3a08560
Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
diff --git a/classes/phosphor-ipmi-host-whitelist.bbclass b/classes/phosphor-ipmi-host-whitelist.bbclass
index a13b0b1..f2b041f 100644
--- a/classes/phosphor-ipmi-host-whitelist.bbclass
+++ b/classes/phosphor-ipmi-host-whitelist.bbclass
@@ -2,7 +2,7 @@
 # packages
 
 WHITELIST ?= "${PN}.conf"
-INSTALLDIR = "${sysconfdir}/phosphor-ipmi-host/"
+INSTALLDIR = "${D}${datadir}/phosphor-ipmi-host/"
 
 python phosphor_ipmi_host_whitelist_postinstall() {
     def install_whitelist(d):
@@ -24,4 +24,4 @@
 
     install_whitelist(d)
 }
-do_populate_sysroot[postfuncs] += "phosphor_ipmi_host_whitelist_postinstall"
+do_install[postfuncs] += "phosphor_ipmi_host_whitelist_postinstall"