ssh: Allow ssh authentication only for admin priv

Restrict SSH authentication only for priv-admin users
instead of all privileged users, for security reasons.
This avoids low level privilege user in establishing
a SSH connection

Tested:
1. Verified ssh works fine for any priv-admin user
2. Blocked for all other non-admin users.

Change-Id: Ic6df8de949751199a1b43fef80c6046ba972c343
Signed-off-by: Richard Marian Thomaiyar <richard.marian.thomaiyar@linux.intel.com>
diff --git a/recipes-core/dropbear/dropbear_%.bbappend b/recipes-core/dropbear/dropbear_%.bbappend
index cab454a..e3749ac 100644
--- a/recipes-core/dropbear/dropbear_%.bbappend
+++ b/recipes-core/dropbear/dropbear_%.bbappend
@@ -3,4 +3,6 @@
 # to yocto 2.5 or later which will pull in the latest dropbear code.
 FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
 SRC_URI += "file://dropbearkey.service \
-            file://localoptions.h"
+            file://localoptions.h \
+            file://dropbear.default \
+           "