Add virtual/phosphor-ipmi-inventory-sel

This virtual provides a YAML file that serves as a mapping between
inventory and sensor number for phosphor-ipmi-host. Add a native
recipe that builds the YAML from the MRW. This is the default for
the machines that support obmc-mrw.

Resolves openbmc/openbmc#1514

Change-Id: I3d856ab00c34d3e71926b863f207dd69f7fc8f3f
Signed-off-by: Tom Joseph <tomjoseph@in.ibm.com>
diff --git a/common/recipes-phosphor/ipmi/phosphor-ipmi-inventory-sel-native.bb b/common/recipes-phosphor/ipmi/phosphor-ipmi-inventory-sel-native.bb
new file mode 100644
index 0000000..272e533
--- /dev/null
+++ b/common/recipes-phosphor/ipmi/phosphor-ipmi-inventory-sel-native.bb
@@ -0,0 +1,21 @@
+SUMMARY = "Inventory to Sensor config for non-mrw machines"
+PR = "r1"
+
+inherit native
+inherit phosphor-ipmi-host
+inherit obmc-phosphor-license
+
+PROVIDES += "virtual/phosphor-ipmi-inventory-sel"
+
+SRC_URI += "file://config.yaml"
+
+S = "${WORKDIR}"
+
+do_install() {
+        # This recipe would provide the sample inventory to sensor config
+        # mapping, for non-mrw machines.
+
+        DEST=${D}${sensor_datadir}
+        install -d ${DEST}
+        install config.yaml ${DEST}/invsensor.yaml
+}