Add recipe that facilitates in error metadata generation

New error log native recipe added which will be built before
phosphor-logging recipe.

Applications that have error yaml files need to add a native
recipe that copies the error yaml files to a known location
and add a DEPEND relationship with this error log native
recipe.

phosphor-logging will have a DEPEND's relationship on the
error log native recipe.

error log native recipe ensure's that all the error log yaml
files are available in the known location before
phosphor-logging is built.

phosphor-logging during the build process will pick all the
error yaml files from the known location and generates error
meta data.

Change-Id: I1a4c627ced854241cafa41d0d6388ef69c8b0356
Signed-off-by: Marri Devender Rao <devenrao@in.ibm.com>
diff --git a/common/recipes-phosphor/logging/phosphor-logging-error-logs-native.bb b/common/recipes-phosphor/logging/phosphor-logging-error-logs-native.bb
new file mode 100644
index 0000000..94518d9
--- /dev/null
+++ b/common/recipes-phosphor/logging/phosphor-logging-error-logs-native.bb
@@ -0,0 +1,13 @@
+SUMMARY = "Phosphor OpenBMC - eror log meta data generation"
+PR = "r1"
+
+inherit native
+inherit obmc-phosphor-license
+
+#To append new recipes that copies error yaml files to the known
+#location, add DEPENDS relationhip using bbappend to
+#phosphor-logging-error-log-native recipe with the native
+#recipe name
+
+#Refer to openpower-debug-collector-error-native.bb to see how
+#to copy error yaml files to a known location