Add recipe that facilitates in error metadata generation

New error log native recipe added which will be built before
phosphor-logging recipe.

Applications that have error yaml files need to add a native
recipe that copies the error yaml files to a known location
and add a DEPEND relationship with this error log native
recipe.

phosphor-logging will have a DEPEND's relationship on the
error log native recipe.

error log native recipe ensure's that all the error log yaml
files are available in the known location before
phosphor-logging is built.

phosphor-logging during the build process will pick all the
error yaml files from the known location and generates error
meta data.

Change-Id: I1a4c627ced854241cafa41d0d6388ef69c8b0356
Signed-off-by: Marri Devender Rao <devenrao@in.ibm.com>
diff --git a/common/recipes-phosphor/logging/phosphor-logging.bb b/common/recipes-phosphor/logging/phosphor-logging.bb
index 0fda3da..c2bc8bc 100644
--- a/common/recipes-phosphor/logging/phosphor-logging.bb
+++ b/common/recipes-phosphor/logging/phosphor-logging.bb
@@ -20,6 +20,7 @@
 DEPENDS += "sdbusplus sdbusplus-native"
 DEPENDS += "phosphor-dbus-interfaces phosphor-dbus-interfaces-native"
 DEPENDS += "virtual/phosphor-logging-callouts"
+DEPENDS += "phosphor-logging-error-logs-native"
 RDEPENDS_${PN} += "sdbusplus phosphor-dbus-interfaces"
 PROVIDES += "virtual/obmc-logging-mgmt"
 RPROVIDES_${PN} += "virtual-obmc-logging-mgmt"