phosphor-dbus-interfaces: add sstate hint for pdi_meson_config

We were seeing intermittent CI failures where the header files
do not include `org.open_power` when building openpower machines.
I suspect this is due to incorrect sstate hints causing an openpower
machine to use header files generated from an x86 machine.

To fix this add a 'vardep' hint to the 'pdi_meson_config' function,
which is used to formulate the EXTRA_OEMESON config flags to meson.

Looking at `bitbake-dumpsig` output before change:
    List of dependencies for variable EXTRA_OEMESON is
    {'PACKAGECONFIG_CONFARGS', 'pdi_meson_config'}
    List of dependencies for variable pdi_meson_config is
    {'listvar_to_list'}

After change:
    List of dependencies for variable EXTRA_OEMESON is
    {'pdi_meson_config', 'PACKAGECONFIG_CONFARGS'}
    List of dependencies for variable pdi_meson_config is
    {'OBMC_ORG_YAML_SUBDIRS', 'listvar_to_list'}

OBMC_ORG_YAML_SUBDIRS has now been added to the variable dependency for
the sstate hash calculation, which is where the needed interfaces are
defined.

Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
Change-Id: I9e9a1249f509904b56efd990c0ffa18dd0b8d801
diff --git a/recipes-phosphor/dbus/phosphor-dbus-interfaces_git.bb b/recipes-phosphor/dbus/phosphor-dbus-interfaces_git.bb
index 835abaf..cb7c64b 100644
--- a/recipes-phosphor/dbus/phosphor-dbus-interfaces_git.bb
+++ b/recipes-phosphor/dbus/phosphor-dbus-interfaces_git.bb
@@ -27,5 +27,6 @@
         '-Ddata_' + x.replace('/', '_') + '=true' \
                 for x in listvar_to_list(d, 'OBMC_ORG_YAML_SUBDIRS')
         ])
+pdi_meson_config[vardeps] = "OBMC_ORG_YAML_SUBDIRS"
 
 EXTRA_OEMESON_append = " ${@pdi_meson_config(d)}"