Add virtual workbook / config-in-skeleton classes

This patch introduces a new abstraction 'skeleton-workbook'
for representing a system configuration.  At present it is
pulled in by the skeleton recipe so the requirement on what is
implemented by a package providing obmc-phosphor-workbook is something
compatible with the existing System.py python modules in skeleton.

Additionally this patch adds a new recipe for each system using
a configuration file from skeleton today, and a class for common
configuration.

This enables a couple of things:
 - No need to patch skeleton.service for each system.
 - New systems don't have to put their configuration in the skeleton
     repository.

Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/common/recipes-phosphor/skeleton/skeleton.bb b/common/recipes-phosphor/skeleton/skeleton.bb
index eb45a40..9762792 100644
--- a/common/recipes-phosphor/skeleton/skeleton.bb
+++ b/common/recipes-phosphor/skeleton/skeleton.bb
@@ -14,8 +14,10 @@
 inherit pythonnative
 inherit python-dir
 
+VIRTUAL-RUNTIME_skeleton_workbook ?= ""
+
 DEPENDS += "glib-2.0 systemd"
-RDEPENDS_${PN} += "python-subprocess python-compression libsystemd"
+RDEPENDS_${PN} += "python-subprocess python-compression libsystemd ${VIRTUAL-RUNTIME_skeleton_workbook}"
 SRC_URI += "git://github.com/openbmc/skeleton"
 
 FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}/*"
@@ -41,7 +43,7 @@
 
 do_install() {
         oe_runmake -C git install \
-		PYTHON=${PYTHON} \
-		DESTDIR=${D} \
-		PREFIX=/usr
+                PYTHON=${PYTHON} \
+                DESTDIR=${D} \
+                PREFIX=/usr
 }