nlohmann: Update to 3.1.2

Change-Id: Ib5bff064f5b158f18268786f5fafd59760a941ac
Tested: Built witherspoon and palmetto images
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/common/recipes-support/nlohmann-json/nlohmann-json_git.bb b/common/recipes-support/nlohmann-json/nlohmann-json_git.bb
index 57a0bad..bbb63a1 100644
--- a/common/recipes-support/nlohmann-json/nlohmann-json_git.bb
+++ b/common/recipes-support/nlohmann-json/nlohmann-json_git.bb
@@ -1,18 +1,18 @@
 DESCRIPTION = "JSON for modern C++"
 HOMEPAGE = "https://nlohmann.github.io/json/"
 LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE.MIT;md5=f8a8f918f1513404c8366d7a63ab6d97"
+LIC_FILES_CHKSUM = "file://LICENSE.MIT;md5=9a8ae1c2d606c432a2aa2e2de15be22a"
 
 SRC_URI = "git://github.com/nlohmann/json.git"
 
 ALLOW_EMPTY_${PN} = "1"
 
-PV = "3.0.1+git${SRCPV}"
+PV = "3.1.2+git${SRCPV}"
 
-SRCREV = "ce1dccf347faf6beb2cdf06b788c01cc24e4c6ce"
+SRCREV = "183390c10b8ba4aa33934ae593f82f352befefc8"
 
 S = "${WORKDIR}/git"
 do_install_append(){
     install -d ${D}${includedir}/nlohmann
-    install -m 644 ${S}/src/json.hpp ${D}${includedir}/nlohmann/json.hpp
+    install -m 644 ${S}/single_include/nlohmann/json.hpp ${D}${includedir}/nlohmann/json.hpp
 }