aspeed: Add cf-fsi firmware

This project installs the machine specific ColdFire firmware file into
/lib/firmware for using the ColdFire FSI master kenrel driver.

The repository contains source and corresponding assembled binaries. We
do not assemble our own binaries as that would require building binutils
for the 68k.

Change-Id: Iac13f94532e0cdf92814f2521f170778505f30f7
Signed-off-by: Joel Stanley <joel@jms.id.au>
diff --git a/aspeed-layer/recipes-kernel/cf-fsi-firmware/cf-fsi-firmware.bb b/aspeed-layer/recipes-kernel/cf-fsi-firmware/cf-fsi-firmware.bb
new file mode 100644
index 0000000..5e864e6
--- /dev/null
+++ b/aspeed-layer/recipes-kernel/cf-fsi-firmware/cf-fsi-firmware.bb
@@ -0,0 +1,25 @@
+SUMMARY = "Firmware for using the ASPEED ColdFire FSI master"
+SECTION = "kenrel"
+
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
+
+SRCREV = "0573025f0147171297c770f31619bd19afe971cf"
+SRC_URI = "git://github.com/ozbenh/cf-fsi.git"
+
+S = "${WORKDIR}/git"
+
+inherit allarch
+
+do_compile() {
+	:
+}
+
+firmware_dir="${nonarch_base_libdir}/firmware/"
+
+do_install() {
+	install -d ${D}${firmware_dir}
+	install -m 0644 ${S}/dist-bin/cf-fsi-${MACHINE}.bin ${D}${firmware_dir}
+}
+
+FILES_${PN} = "${firmware_dir}"