Add group names based on recipe

Add ipmi, web, and redfish to the /etc/group file from own recipe.
Note: phosphor-user-manager relies on this group names to manage
access control

Change-Id: I89bb1bc87244eb80880febe451d9f6b78322b928
Signed-off-by: Richard Marian Thomaiyar <richard.marian.thomaiyar@linux.intel.com>
diff --git a/recipes-phosphor/ipmi/phosphor-ipmi-host.bb b/recipes-phosphor/ipmi/phosphor-ipmi-host.bb
index 7a2f7c1..667ea1c 100644
--- a/recipes-phosphor/ipmi/phosphor-ipmi-host.bb
+++ b/recipes-phosphor/ipmi/phosphor-ipmi-host.bb
@@ -47,6 +47,12 @@
 RDEPENDS_${PN} += "${VIRTUAL-RUNTIME_ipmi-config}"
 RDEPENDS_${PN} += "virtual/obmc-watchdog"
 
+inherit useradd
+
+USERADD_PACKAGES = "${PN}"
+# add ipmi group
+GROUPADD_PARAM_${PN} = "ipmi"
+
 SYSTEMD_SERVICE_${PN} += "xyz.openbmc_project.Ipmi.Internal.SoftPowerOff.service phosphor-ipmi-host.service"
 
 RRECOMMENDS_${PN} += "${VIRTUAL-RUNTIME_obmc-settings-mgmt}"