Brad Bishop | 80fac6d | 2016-06-07 16:25:54 -0400 | [diff] [blame] | 1 | SUMMARY = "U-Boot bootloader image creation tool" |
| 2 | LICENSE = "GPLv2+" |
| 3 | LIC_FILES_CHKSUM = "file://Licenses/README;md5=a2c678cfd4a4d97135585cad908541c6" |
| 4 | SECTION = "bootloader" |
| 5 | |
| 6 | DEPENDS = "openssl" |
| 7 | |
Joel Stanley | 2ed0329 | 2017-05-26 14:27:34 +1000 | [diff] [blame] | 8 | SRCREV = "a5e0a21ed4b62ab4d8ff09f70b751db0f46ddaac" |
Joel Stanley | 7741d65 | 2016-07-27 18:33:40 +0930 | [diff] [blame] | 9 | UBRANCH = "v2016.07-aspeed-openbmc" |
Brad Bishop | 80fac6d | 2016-06-07 16:25:54 -0400 | [diff] [blame] | 10 | SRC_URI = "git://git@github.com/openbmc/u-boot.git;branch=${UBRANCH};protocol=https" |
| 11 | |
Joel Stanley | 7741d65 | 2016-07-27 18:33:40 +0930 | [diff] [blame] | 12 | PV = "v2016.07+git${SRCPV}" |
Brad Bishop | 80fac6d | 2016-06-07 16:25:54 -0400 | [diff] [blame] | 13 | |
| 14 | S = "${WORKDIR}/git" |
| 15 | |
| 16 | EXTRA_OEMAKE = 'CROSS_COMPILE="${TARGET_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" STRIP=true V=1' |
| 17 | |
| 18 | do_compile () { |
| 19 | oe_runmake sandbox_defconfig |
| 20 | oe_runmake cross_tools NO_SDL=1 |
| 21 | } |
| 22 | |
| 23 | do_install () { |
| 24 | install -d ${D}${bindir} |
| 25 | install -m 0755 tools/mkimage ${D}${bindir}/uboot-mkimage |
| 26 | ln -sf uboot-mkimage ${D}${bindir}/mkimage |
| 27 | } |
| 28 | |
| 29 | BBCLASSEXTEND = "native nativesdk" |