blob: 2036ad8fe683d210e430a144f82e050f079bc366 [file] [log] [blame]
Chris Austen737b35f2015-10-25 00:21:04 -05001SUMMARY = "Phosphor OpenBMC Event Management"
2DESCRIPTION = "Phosphor OpenBMC event management reference implementation."
3HOMEPAGE = "https://github.com/causten/openbmc-eventd"
4PR = "r1"
5
6
7inherit obmc-phosphor-license
8inherit obmc-phosphor-event-mgmt
9inherit obmc-phosphor-sdbus-service
10inherit obmc-phosphor-c-daemon
11
12SRC_URI += "git://github.com/causten/openbmc-eventd"
13
14SRCREV = "417f69b7839034543405f1bb70a73cc701a1b3a5"
15
16RDEPENDS_${PN} += "libsystemd"
17DEPENDS += "systemd"
18
19
20S = "${WORKDIR}/git"
21INSTALL_NAME = "event_messaged"
22
23do_install() {
24 install -m 0755 -d ${D}${sbindir}
25 install -m 0755 ${S}/${INSTALL_NAME} ${D}/${sbindir}/obmc-phosphor-eventd
26}