blob: 816073b7e88f5390c0703cf562171f8a98d7c9fd [file] [log] [blame]
Michael Tritz62585f42017-01-25 15:16:04 -06001SUMMARY = "FFDC collector script"
2DESCRIPTION = "Command line tool to collect and tar up debug data"
3PR = "r1"
4
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=<checksum>"
7
8RDEPENDS_${PN} += " \
9 systemd \
10 ${VIRTUAL-RUNTIME_base-utils} \
11 "
12
13S = "${WORKDIR}"
14SRC_URI += "git://github.com/openbmc/phosphor-debug-collector/"
15
16SRCREV = "3e3f28b4fbeada4b3f254d1b2d836c5fcb0bc28f"
17
18do_install() {
19 install -d ${D}${bindir}
20 install -m 0755 ffdc \
21 ${D}${bindir}/ffdc
22}