blob: 60955e56d14b0db9a2564ecc6f2efc26cc120321 [file] [log] [blame]
Brad Bishopb0c3b272017-01-11 11:12:32 -05001SUMMARY = "OpenBMC hwmon poller"
2DESCRIPTION = "OpenBMC hwmon poller."
3PR = "r1"
4
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
7
Brad Bishop030da252017-01-11 15:30:07 -05008inherit autotools pkgconfig obmc-phosphor-systemd
9
10SYSTEMD_SERVICE_${PN} = "xyz.openbmc_project.Hwmon@.service"
Brad Bishopb0c3b272017-01-11 11:12:32 -050011
12DEPENDS += "autoconf-archive-native"
13DEPENDS += "sdbusplus"
14
15RDEPENDS_${PN} += "\
16 libsystemd \
17 "
18
19SRC_URI += "git://github.com/openbmc/phosphor-hwmon"
Brad Bishop030da252017-01-11 15:30:07 -050020SRC_URI += "file://70-hwmon.rules"
Brad Bishopb0c3b272017-01-11 11:12:32 -050021
Patrick Williams4d5947a2017-01-30 15:00:09 -060022SRCREV = "30dbceec70d96487016b129334ba539b9e161c08"
Brad Bishopb0c3b272017-01-11 11:12:32 -050023
24S = "${WORKDIR}/git"
Brad Bishop030da252017-01-11 15:30:07 -050025
26do_install_append() {
27
Brad Bishopf5812fd2017-01-26 09:12:57 -050028 install -d ${D}/${base_libdir}/udev/rules.d/
29 install ${WORKDIR}/70-hwmon.rules ${D}/${base_libdir}/udev/rules.d/
Brad Bishop030da252017-01-11 15:30:07 -050030}