blob: f7e53a28a6d354a969967ddd7665032d408b8a05 [file] [log] [blame]
Artem Senichev8135af92018-11-02 16:46:13 +03001SUMMARY = "Phosphor Host logger"
2DESCRIPTION = "Save log messages from host's console to the persistent storage."
3HOMEPAGE = "https://github.com/openbmc/phosphor-hostlogger"
4PR = "r1"
5PV = "1.0+git${SRCPV}"
6
7inherit autotools
8inherit pkgconfig
9inherit pythonnative
10inherit systemd
11
12# License info
13LICENSE = "Apache-2.0"
14LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
15
16# Dependencies
17DEPENDS += "sdbusplus \
18 sdbusplus-native \
19 phosphor-dbus-interfaces"
20RDEPENDS_${PN} += "obmc-console"
21RRECOMMENDS_${PN} += "phosphor-debug-collector"
22
23# systemd service setup
24SYSTEMD_PACKAGES = "${PN}"
25SYSTEMD_SERVICE_${PN} = "hostlogger.service"
26SYSTEMD_DEFAULT_TARGET ?= "multi-user.target"
27
28# Host TTY setup
29OBMC_CONSOLE_HOST_TTY ?= "ttyVUART0"
30
31# Extra parameters for 'configure' script
32EXTRA_OECONF = "HOST_TTY=${OBMC_CONSOLE_HOST_TTY} \
33 SYSTEMD_TARGET=${SYSTEMD_DEFAULT_TARGET}"
34
35# Source code repository
36S = "${WORKDIR}/git"
37SRC_URI = "git://github.com/openbmc/phosphor-hostlogger"
38SRCREV = "4d5a5dcd6f974166c8d0f2657e0079a7f3fc5e01"