blob: e7e31cf1b952a13df00faa638605d3db1501268b [file] [log] [blame]
Brad Bishop70436da2015-09-16 14:49:27 -04001SUMMARY = "Phosphor OpenBMC REST framework"
2DESCRIPTION = "Phosphor OpenBMC REST to DBUS daemon."
3HOMEPAGE = "http://github.com/openbmc/rest-dbus"
4PR = "r1"
5
6inherit allarch
7inherit obmc-phosphor-license
8inherit obmc-phosphor-systemd
9
Brad Bishop70436da2015-09-16 14:49:27 -040010RDEPENDS_${PN} += " \
11 python-netserver \
12 python-json \
13 python-dbus \
14 python-xml \
15 "
16SRC_URI += " \
17 git://github.com/openbmc/rest-dbus.git \
18 file://makefile.patch \
19 file://resources-path.patch \
20 file://no-session-bus.patch \
21 "
22
23SRCREV = "9b0e0bab5150ccc4333ce442932f8969f365155e"
24
25S = "${WORKDIR}/git"
26
27do_install() {
28 oe_runmake prefix=${D} install
29}