Brad Bishop | 4ccd9f3 | 2015-10-06 00:27:43 -0400 | [diff] [blame] | 1 | DESCRIPTION = "Linux kernel for OpenBMC" |
| 2 | SECTION = "kernel" |
| 3 | LICENSE = "GPLv2" |
| 4 | |
| 5 | KBRANCH ?= "dev" |
| 6 | |
| 7 | SRC_URI = "git://github.com/openbmc/linux;protocol=git;branch=${KBRANCH}" |
Brad Bishop | 4ccd9f3 | 2015-10-06 00:27:43 -0400 | [diff] [blame] | 8 | SRC_URI += "file://obmc-bsp.scc \ |
| 9 | file://obmc-bsp.cfg \ |
| 10 | file://obmc-bsp-user-config.cfg \ |
| 11 | file://obmc-bsp-user-patches.scc \ |
| 12 | " |
| 13 | |
| 14 | LINUX_VERSION ?= "4.2" |
| 15 | LINUX_VERSION_EXTENSION ?= "-openbmc-${SRCPV}" |
| 16 | |
| 17 | SRCREV="${AUTOREV}" |
| 18 | |
| 19 | PV = "${LINUX_VERSION}+git${SRCPV}" |
| 20 | |
| 21 | COMPATIBLE_MACHINE_${MACHINE} = "openbmc" |
| 22 | |
| 23 | inherit kernel |
| 24 | require recipes-kernel/linux/linux-yocto.inc |
| 25 | |
| 26 | do_configure_prepend() { |
| 27 | sed -i 's/CONFIG_LOCALVERSION=.\+/CONFIG_LOCALVERSION=${LINUX_VERSION_EXTENSION}/' ${S}/arch/${ARCH}/configs/${KMACHINE}_defconfig |
| 28 | } |