blob: f55d4718d67d8a296384623b8ac6429bb7525ea6 [file] [log] [blame]
Joel Stanleybc3b51a2018-04-23 10:50:44 +09301HOMEPAGE = "https://github.com/jk-ozlabs/uart-render-controller"
2LICENSE = "GPLv2+"
3
4SRC_URI += "git://github.com/jk-ozlabs/uart-render-controller;branch=master"
5SRC_URI += "file://uart-render-controller.service"
6
7PR = "r1"
8
9LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
10
11inherit autotools
12inherit pkgconfig
13inherit systemd
14
15DEPENDS += "autoconf-archive-native"
16DEPENDS += "systemd"
Joel Stanleybc3b51a2018-04-23 10:50:44 +093017RDEPENDS_${PN} += "fbterm"
18
19SRCREV = "14decab20f621c050760e5f3310f5a960cf21211"
20PV = "0.1+git${SRCPV}"
21
22S = "${WORKDIR}/git"
23
24SYSTEMD_SERVICE_${PN} += "uart-render-controller.service"
25
26do_install_append() {
27 install -d ${D}${systemd_system_unitdir}
28 install -m 0644 ${WORKDIR}/uart-render-controller.service ${D}${systemd_system_unitdir}/
29}