blob: 3dcba8a8653ec8bc70cf9fe28544fe75982cc8cd [file] [log] [blame]
Brad Bishop667938f2017-01-12 21:44:51 -05001SUMMARY = "OpenBMC - Applications"
Brad Bishop93fb5352015-09-09 03:59:20 +00002PR = "r1"
3
4inherit packagegroup
5inherit obmc-phosphor-utils
6inherit obmc-phosphor-license
7
Brad Bishop93fb5352015-09-09 03:59:20 +00008PROVIDES = "${PACKAGES}"
9PACKAGES = " \
Brad Bishop46631702017-03-01 16:16:06 -050010 ${PN}-bmc-state-mgmt \
11 ${PN}-chassis-state-mgmt \
Brad Bishop6165ec32016-09-06 22:44:21 -040012 ${PN}-extras \
13 ${PN}-extrasdev \
Brad Bishop11909e02017-05-01 11:54:34 -040014 ${PN}-fan-control \
Brad Bishop46631702017-03-01 16:16:06 -050015 ${PN}-host-state-mgmt \
Brad Bishop45f8b572017-02-01 21:04:14 -050016 ${PN}-inventory \
17 ${PN}-leds \
18 ${PN}-sensors \
Gunnar Millsc868f922017-02-15 16:01:45 -060019 ${PN}-software \
Brad Bishop93fb5352015-09-09 03:59:20 +000020 "
21
Brad Bishop46631702017-03-01 16:16:06 -050022SUMMARY_${PN}-bmc-state-mgmt = "BMC state management"
23RDEPENDS_${PN}-bmc-state-mgmt = " \
24 ${VIRTUAL-RUNTIME_obmc-bmc-state-manager} \
25 "
26
27SUMMARY_${PN}-chassis-state-mgmt = "Chassis state management"
28RDEPENDS_${PN}-chassis-state-mgmt = " \
29 ${VIRTUAL-RUNTIME_obmc-chassis-state-manager} \
30 "
31
Brad Bishop6165ec32016-09-06 22:44:21 -040032SUMMARY_${PN}-extras = "Extra features"
33RDEPENDS_${PN}-extras = " \
Brad Bishop667938f2017-01-12 21:44:51 -050034 phosphor-rest \
Brad Bishop70436da2015-09-16 14:49:27 -040035 "
36
Brad Bishop6165ec32016-09-06 22:44:21 -040037SUMMARY_${PN}-extrasdev = "Development features"
38RDEPENDS_${PN}-extrasdev = " \
Adriana Kobylakeaa56c92016-06-16 14:46:06 -050039 rest-dbus \
40 "
Brad Bishop45f8b572017-02-01 21:04:14 -050041
Brad Bishop11909e02017-05-01 11:54:34 -040042# Use the fan control package group for applications
43# implementing fan control or system fan policy only.
44# Applications that create inventory or sensors should
45# be added those respective package groups instead.
46SUMMARY_${PN}-fan-control = "Fan control"
47RDEPENDS_${PN}-fan-control = " \
48 "
49
Brad Bishop46631702017-03-01 16:16:06 -050050SUMMARY_${PN}-host-state-mgmt = "Host state management"
51RDEPENDS_${PN}-host-state-mgmt = " \
52 ${VIRTUAL-RUNTIME_obmc-host-state-manager} \
Michael Tritz1f792e02017-03-31 12:04:32 -050053 ${VIRTUAL-RUNTIME_obmc-discover-system-state} \
Brad Bishop46631702017-03-01 16:16:06 -050054 "
55
Brad Bishop45f8b572017-02-01 21:04:14 -050056SUMMARY_${PN}-inventory = "Inventory applications"
57RDEPENDS_${PN}-inventory = " \
58 ${VIRTUAL-RUNTIME_obmc-inventory-manager} \
Matthew Barth91460422017-02-24 13:14:43 -060059 ${VIRTUAL-RUNTIME_obmc-fan-presence} \
Brad Bishop98cea152017-04-11 22:12:56 -040060 phosphor-chassis-cooling-type \
Brad Bishop45f8b572017-02-01 21:04:14 -050061 "
62
63SUMMARY_${PN}-leds = "LED applications"
64RDEPENDS_${PN}-leds = " \
Brad Bishopc1d30c52017-02-27 11:59:49 -050065 ${VIRTUAL-RUNTIME_obmc-leds-manager} \
66 ${VIRTUAL-RUNTIME_obmc-leds-sysfs} \
Brad Bishop45f8b572017-02-01 21:04:14 -050067 "
68
69SUMMARY_${PN}-sensors = "Sensor applications"
70RDEPENDS_${PN}-sensors = " \
71 ${VIRTUAL-RUNTIME_obmc-sensors-hwmon} \
72 "
Gunnar Millsc868f922017-02-15 16:01:45 -060073
74SUMMARY_${PN}-software = "Software applications"
75RDEPENDS_${PN}-software = " \
76 ${VIRTUAL-RUNTIME_obmc-bmc-code-mgr} \
Deepak Kodihalli60d1de52017-04-13 23:23:42 -050077 ${VIRTUAL-RUNTIME_obmc-bmc-download-mgr} \
Gunnar Millsc868f922017-02-15 16:01:45 -060078 "