blob: a7a650ccbeb61bd8c5b1c4323ddf7ebe9bc1ca62 [file] [log] [blame]
Brad Bishopb0c3b272017-01-11 11:12:32 -05001SUMMARY = "OpenBMC hwmon poller"
2DESCRIPTION = "OpenBMC hwmon poller."
3PR = "r1"
4
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
7
Brad Bishop030da252017-01-11 15:30:07 -05008inherit autotools pkgconfig obmc-phosphor-systemd
9
Brad Bishop1d34ddd2017-08-01 21:33:30 -040010PACKAGE_BEFORE_PN = "max31785-msl"
11SYSTEMD_PACKAGES = "${PN} max31785-msl"
12
Brad Bishop030da252017-01-11 15:30:07 -050013SYSTEMD_SERVICE_${PN} = "xyz.openbmc_project.Hwmon@.service"
Brad Bishop1d34ddd2017-08-01 21:33:30 -040014SYSTEMD_SERVICE_max31785-msl = "phosphor-max31785-msl@.service"
Brad Bishopb0c3b272017-01-11 11:12:32 -050015
16DEPENDS += "autoconf-archive-native"
Brad Bishopf4393bf2017-02-20 14:36:31 -050017DEPENDS += " \
18 sdbusplus \
19 phosphor-dbus-interfaces \
20 phosphor-logging \
21 "
22
Brad Bishopb0c3b272017-01-11 11:12:32 -050023
24RDEPENDS_${PN} += "\
Brad Bishopf4393bf2017-02-20 14:36:31 -050025 sdbusplus \
26 phosphor-dbus-interfaces \
27 phosphor-logging \
Brad Bishopb0c3b272017-01-11 11:12:32 -050028 "
29
Brad Bishopfe7871c2017-02-22 20:50:13 -050030RRECOMMENDS_${PN} += "${VIRTUAL-RUNTIME_phosphor-hwmon-config}"
31
Brad Bishop1d34ddd2017-08-01 21:33:30 -040032FILES_max31785-msl = "${bindir}/max31785-msl"
33RDEPENDS_max31785-msl = "${VIRTUAL-RUNTIME_base-utils} i2c-tools"
34
Brad Bishopb0c3b272017-01-11 11:12:32 -050035SRC_URI += "git://github.com/openbmc/phosphor-hwmon"
Brad Bishop030da252017-01-11 15:30:07 -050036SRC_URI += "file://70-hwmon.rules"
Brandon Wyman675ce0b2017-06-21 16:32:56 -050037SRC_URI += "file://70-iio.rules"
Brad Bishopb0c3b272017-01-11 11:12:32 -050038
Andrew Geissler861b9322018-03-14 07:40:15 +000039SRCREV = "147b0337b36e58604fbdd517f71f97a4dae725c1"
Brad Bishopb0c3b272017-01-11 11:12:32 -050040
41S = "${WORKDIR}/git"
Brad Bishop030da252017-01-11 15:30:07 -050042
43do_install_append() {
44
Brad Bishopf5812fd2017-01-26 09:12:57 -050045 install -d ${D}/${base_libdir}/udev/rules.d/
46 install ${WORKDIR}/70-hwmon.rules ${D}/${base_libdir}/udev/rules.d/
Brandon Wyman675ce0b2017-06-21 16:32:56 -050047 install ${WORKDIR}/70-iio.rules ${D}/${base_libdir}/udev/rules.d/
Brad Bishop030da252017-01-11 15:30:07 -050048}