blob: 90ab40edfc9a57c48933fec1fc8048ed0cdf5a29 [file] [log] [blame]
Matt Spinler23f28832016-09-07 13:39:18 -05001SUMMARY = "Phosphor Inventory Generation"
2DESCRIPTION = "Generates inventory data from the machine readable workbook"
3PR = "r1"
4
5S = "${WORKDIR}/git"
6
7RPROVIDES_${PN} = "virtual-system-inventory-data"
8
9inherit allarch
10inherit obmc-phosphor-license
11
12DEPENDS += "mrw-native mrw-api-native"
13
14SRC_URI += "git://github.com/openbmc/phosphor-mrw-tools"
Patrick Williams01b21ac2016-09-14 22:00:05 -050015SRCREV = "7a68567af7bf121143ef135152a39723518b6e06"
Matt Spinler23f28832016-09-07 13:39:18 -050016
17FILES_${PN} += "${datadir}/inventory"
18
19do_compile() {
20 ${STAGING_BINDIR_NATIVE}/perl-native/perl ${S}/inventory.pl \
21 -x ${STAGING_DATADIR_NATIVE}/obmc-mrw/${MACHINE}.xml -o inventory.json
22}
23
24do_install() {
25 install -d ${D}${datadir}/inventory
26 install -m 0644 inventory.json ${D}${datadir}/inventory/inventory.json
27}