blob: d9a9c66780f4f16d3b7105a43da921cc7394633f [file] [log] [blame]
Brad Bishopf1cc41b2017-05-31 14:08:33 -04001SUMMARY = "Phosphor DBus Monitor"
2DESCRIPTION = "Phosphor DBus Monitor is a general purpose DBus application \
3that watches DBus traffic for events and takes actions based on those events."
4PR = "r1"
5
6HOMEPAGE = "http://github.com/openbmc/phosphor-dbus-monitor"
7LICENSE = "Apache-2.0"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
9SRC_URI = "git://github.com/openbmc/phosphor-dbus-monitor"
Patrick Williams9f964132017-08-14 14:10:04 -050010SRCREV = "2df09e242d6dd5961d831bd179f73489eba526ed"
Brad Bishopf1cc41b2017-05-31 14:08:33 -040011
12inherit autotools \
13 pkgconfig \
14 pythonnative \
15 phosphor-dbus-monitor \
16 obmc-phosphor-systemd
17
18DEPENDS += " \
19 ${PN}-config-native \
20 phosphor-logging \
21 autoconf-archive-native \
22 gtest \
23 "
24RDEPENDS_${PN} += " \
25 sdbusplus \
26 phosphor-dbus-interfaces \
27 phosphor-logging \
28 "
29
30S = "${WORKDIR}/git"
31
32EXTRA_OECONF = " \
33 YAML_PATH=${STAGING_DIR_NATIVE}${config_dir} \
34 "