Add LED config for Centriq2400

For control centriq2400 LED

Change-Id: I9f8b89125a1e94e1bfda46fd7b23993a4b587556
Signed-off-by: Ken Chen <chen.kenyy@inventec.com>
diff --git a/meta-centriq2400-rep/recipes-phosphor/leds/centriq2400-rep-led-manager-config-native.bb b/meta-centriq2400-rep/recipes-phosphor/leds/centriq2400-rep-led-manager-config-native.bb
new file mode 100644
index 0000000..24cf272
--- /dev/null
+++ b/meta-centriq2400-rep/recipes-phosphor/leds/centriq2400-rep-led-manager-config-native.bb
@@ -0,0 +1,18 @@
+SUMMARY = "Phosphor LED Group Management for Centriq2400 REP"
+PR = "r1"
+
+inherit native
+inherit obmc-phosphor-utils
+inherit obmc-phosphor-license
+
+PROVIDES += "virtual/phosphor-led-manager-config-native"
+
+SRC_URI += "file://led.yaml"
+S = "${WORKDIR}"
+
+# Copies example led layout yaml file
+do_install() {
+    SRC=${S}
+    DEST=${D}${datadir}/phosphor-led-manager
+    install -D ${SRC}/led.yaml ${DEST}/led.yaml
+}