meta-quanta: gbs: detect SlimSAS cable presence

Add gpio configuration for SlimSAS cable0~3 and
detect cables connected or not

Signed-off-by: George Hung <george.hung@quantatw.com>
Change-Id: I46f48dab5f11117cd1ee1fb770ae111cbf80cf89
diff --git a/meta-gbs/recipes-gbs/detect-sas-cable/gbs-detect-sas-cable.bb b/meta-gbs/recipes-gbs/detect-sas-cable/gbs-detect-sas-cable.bb
new file mode 100644
index 0000000..74785ef
--- /dev/null
+++ b/meta-gbs/recipes-gbs/detect-sas-cable/gbs-detect-sas-cable.bb
@@ -0,0 +1,25 @@
+SUMMARY = "OpenBMC Quanta Detect SAS Cable Service"
+DESCRIPTION = "OpenBMC Quanta Detect SAS Cable Daemon."
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+inherit systemd
+
+DEPENDS += "systemd"
+RDEPENDS_${PN} += "bash"
+
+SRC_URI =  " file://detect-sas-cable.sh \
+             file://detect-sas-cable.service \
+            "
+
+do_install() {
+    install -d ${D}${bindir}
+    install -m 0755 ${WORKDIR}/detect-sas-cable.sh ${D}${bindir}/
+
+    install -d ${D}${systemd_system_unitdir}
+    install -m 0644 ${WORKDIR}/detect-sas-cable.service ${D}${systemd_system_unitdir}
+}
+
+SYSTEMD_PACKAGES = "${PN}"
+SYSTEMD_SERVICE_${PN} = "detect-sas-cable.service"