meta-quanta: meta-common: Add "mac-address" and "usb-network" services

Add two services into meta-quanta/meta-common:
(1)mac-address
(2)usb-network

These two service is used to set network config when initialize system.

Signed-off-by: Spencer Ku <Spencer.Ku@quantatw.com>
Change-Id: I599009531559613c276bc2e9d20666061ea3b37a
diff --git a/meta-common/network/mac-address_git.bb b/meta-common/network/mac-address_git.bb
new file mode 100644
index 0000000..5b63e49
--- /dev/null
+++ b/meta-common/network/mac-address_git.bb
@@ -0,0 +1,21 @@
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
+
+inherit autotools pkgconfig
+inherit systemd
+
+S = "${WORKDIR}/git"
+SRC_URI = "git://github.com/quanta-bmc/mac-address.git;protocol=git"
+SRCREV = "08b87370c56ff69df852eca87391ae46c05d437a"
+
+DEPENDS += "autoconf-archive-native"
+DEPENDS += "systemd"
+
+FILES_${PN} += "${bindir}/mac-address"
+
+SYSTEMD_PACKAGES = "${PN}"
+SYSTEMD_SERVICE_${PN} = "mac-address.service"
+
+EXTRA_OECONF = " \
+    SYSTEMD_TARGET="multi-user.target" \
+"