Configure hwmon to remove objects on fails

phosphor-hwmon changed its default behavior to exit
the program on an access failure.  To preserve the
behavior that this platform needs, an option needs
to be passed to the configure step.

Resolves openbmc/openbmc#2111

Change-Id: I124178629be25c7758e59ba356bb1c5dc3e4b57d
Signed-off-by: Matt Spinler <spinler@us.ibm.com>
diff --git a/meta-q71l/recipes-phosphor/sensors/phosphor-hwmon%.bbappend b/meta-q71l/recipes-phosphor/sensors/phosphor-hwmon%.bbappend
index 3557b74..fb58eeb 100644
--- a/meta-q71l/recipes-phosphor/sensors/phosphor-hwmon%.bbappend
+++ b/meta-q71l/recipes-phosphor/sensors/phosphor-hwmon%.bbappend
@@ -10,3 +10,5 @@
 
 ENVS = "obmc/hwmon/{0}"
 SYSTEMD_ENVIRONMENT_FILE_${PN}_append_quanta-q71l := " ${@compose_list(d, 'ENVS', 'ITEMS')}"
+
+EXTRA_OECONF_append_quanta-q71l = " --enable-remove-from-dbus-on-fail"