meta-quanta: gbs: add updating nvme config script

Update Present/Pwrgood GPIOs number to nvme json config and
export them before running phosphor-nvme daemon

Signed-off-by: George Hung <george.hung@quantatw.com>
Change-Id: Ic9f8688b2c5f2db6c5309f023770a240b3dec816
diff --git a/meta-gbs/recipes-phosphor/sensors/phosphor-nvme_%.bbappend b/meta-gbs/recipes-phosphor/sensors/phosphor-nvme_%.bbappend
new file mode 100644
index 0000000..c3db11d
--- /dev/null
+++ b/meta-gbs/recipes-phosphor/sensors/phosphor-nvme_%.bbappend
@@ -0,0 +1,17 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+SRC_URI_append_gbs = " file://nvme_config.json"
+SRC_URI_append_gbs = " file://nvme_json_rewrite.sh"
+SRC_URI_append_gbs = " file://xyz.openbmc_project.nvme.manager.service.replace"
+
+RDEPENDS_${PN} += "bash"
+
+do_install_append_gbs() {
+        install -d ${D}/${sysconfdir}/nvme/
+        install -m 0644 ${WORKDIR}/nvme_config.json ${D}/${sysconfdir}/nvme/
+
+        install -d ${D}${bindir}
+        install -m 0755 ${WORKDIR}/nvme_json_rewrite.sh ${D}${bindir}/
+
+        install -d ${D}${systemd_system_unitdir}
+        install -m 0644 ${WORKDIR}/xyz.openbmc_project.nvme.manager.service.replace ${D}${systemd_system_unitdir}/xyz.openbmc_project.nvme.manager.service
+}