meta-quanta: gbs: add GBS read-margin-temp config

Since read-margin-temp_git.bb will move to meta-quanta/meta-common,
add read-margin-temp bbappend file and move read-margin-temp folder
from meta-gbs/recipes-phosphor/fans to meta-gbs/recipes-quanta/fans

read-margin-temp_git.bb move to meta-quanta/meta-common:
https://gerrit.openbmc-project.xyz/c/openbmc/meta-quanta/+/35277

Signed-off-by: George Hung <george.hung@quantatw.com>
Change-Id: I08a4fd7e258a7950462f0f77b584743ec4517bc5
diff --git a/meta-gbs/recipes-quanta/fans/read-margin-temp_%.bbappend b/meta-gbs/recipes-quanta/fans/read-margin-temp_%.bbappend
new file mode 100644
index 0000000..b3fc4d2
--- /dev/null
+++ b/meta-gbs/recipes-quanta/fans/read-margin-temp_%.bbappend
@@ -0,0 +1,16 @@
+FILESEXTRAPATHS_prepend_gbs := "${THISDIR}/${PN}:"
+SRC_URI_append_gbs = " file://config-margin.json \
+                       file://read-margin-temp-wait.sh \
+                     "
+
+FILES_${PN}_append_gbs = " ${bindir}/read-margin-temp-wait.sh"
+FILES_${PN}_append_gbs = " ${datadir}/read-margin-temp/config-margin.json"
+
+do_install_append_gbs() {
+    install -d ${D}${bindir}
+    install -m 0755 ${WORKDIR}/read-margin-temp-wait.sh ${D}${bindir}
+
+    install -d ${D}${datadir}/read-margin-temp
+    install -m 0644 -D ${WORKDIR}/config-margin.json \
+        ${D}${datadir}/read-margin-temp/config-margin.json
+}