meta-quanta: gbs: add GBS Entity Association Map

Add entity association map for Google OEM
IPMI command (get entity name)

Tested:
For example, get entity name, "fan0":
~# ipmitool raw 0x2e 0x32 0x79 0x2b 0x00 0x06 0x1d 0x00
  79 2b 00 06 05 2f 66 61 6e 30

Signed-off-by: George Hung <george.hung@quantatw.com>
Change-Id: I5f36b64d750245e34c16a234300a295e1f7c1d8a
diff --git a/meta-gbs/recipes-gbs/gbs-ipmi-entity-association-map/gbs-ipmi-entity-association-map.bb b/meta-gbs/recipes-gbs/gbs-ipmi-entity-association-map/gbs-ipmi-entity-association-map.bb
new file mode 100644
index 0000000..8b5551e
--- /dev/null
+++ b/meta-gbs/recipes-gbs/gbs-ipmi-entity-association-map/gbs-ipmi-entity-association-map.bb
@@ -0,0 +1,16 @@
+SUMMARY = "GBS IPMI Entity association mapping."
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+SRC_URI += "file://entity_association_map.json"
+
+FILES_${PN} = " \
+    ${datadir}/ipmi-entity-association/entity_association_map.json \
+    "
+
+do_install() {
+    install -d ${D}${datadir}/ipmi-entity-association
+    install -m 0644 -D ${WORKDIR}/entity_association_map.json \
+        ${D}${datadir}/ipmi-entity-association/entity_association_map.json
+}