meta-quanta: gbs: add LED configuration

Set GBS related LED actions in yaml file
1. heartbeat
2. sys boot status (bios post done)
3. attention (identify)
4. bmc fault (kernel panic)
5. NVME SSD locate/fault

Signed-off-by: George Hung <george.hung@quantatw.com>
Change-Id: I3f9d06e5f81fc5737683198d0dc8c896078f971b
diff --git a/meta-gbs/recipes-phosphor/leds/gbs-led-manager-config-native.bb b/meta-gbs/recipes-phosphor/leds/gbs-led-manager-config-native.bb
new file mode 100644
index 0000000..03b5620
--- /dev/null
+++ b/meta-gbs/recipes-phosphor/leds/gbs-led-manager-config-native.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Phosphor LED Group Management for GBS"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+inherit native
+
+PROVIDES += "virtual/phosphor-led-manager-config-native"
+
+SRC_URI += "file://led.yaml"
+S = "${WORKDIR}"
+
+# Overwrite the example led layout yaml file prior
+# to building the phosphor-led-manager package
+do_install() {
+    SRC=${S}
+    DEST=${D}${datadir}/phosphor-led-manager
+    install -D ${SRC}/led.yaml ${DEST}/led.yaml
+}