Add sensor and some FRU definitions for ipmi.

When phosphor-ipmi-host supports returning sensor data, this is
the file it will use to build the cpp map and provide the information.

This has been tested on my platform via ipmitool from the host.

Change-Id: Ie5b0696935d23d6f50c9f62ddb583618a9f3ff91
Signed-off-by: Patrick Venture <venture@google.com>
diff --git a/meta-q71l/recipes-phosphor/ipmi/q71l-ipmi-inventory-map-native.bb b/meta-q71l/recipes-phosphor/ipmi/q71l-ipmi-inventory-map-native.bb
new file mode 100644
index 0000000..dc19aa4
--- /dev/null
+++ b/meta-q71l/recipes-phosphor/ipmi/q71l-ipmi-inventory-map-native.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Quanta Q71l IPMI to DBus Inventory mapping."
+PR = "r1"
+
+inherit native
+inherit obmc-phosphor-license
+inherit phosphor-ipmi-fru
+
+SRC_URI += "file://config.yaml"
+
+PROVIDES += "virtual/phosphor-ipmi-fru-inventory"
+
+S = "${WORKDIR}"
+
+do_install() {
+        # TODO: install this to inventory_datadir
+        # after ipmi-fru-parser untangles the host
+        # firmware config from the machine inventory.
+        DEST=${D}${config_datadir}
+
+        install -d ${DEST}
+        install config.yaml ${DEST}
+}