Add sensor and some FRU definitions for ipmi.

When phosphor-ipmi-host supports returning sensor data, this is
the file it will use to build the cpp map and provide the information.

This has been tested on my platform via ipmitool from the host.

Change-Id: Ie5b0696935d23d6f50c9f62ddb583618a9f3ff91
Signed-off-by: Patrick Venture <venture@google.com>
diff --git a/meta-q71l/recipes-phosphor/workbook/quanta-q71l-config.bb b/meta-q71l/recipes-phosphor/workbook/quanta-q71l-config.bb
new file mode 100644
index 0000000..647633f
--- /dev/null
+++ b/meta-q71l/recipes-phosphor/workbook/quanta-q71l-config.bb
@@ -0,0 +1,37 @@
+SUMMARY = "Quanta Q71l board wiring"
+DESCRIPTION = "Board wiring information for the Quanta Q71l system."
+PR = "r1"
+
+inherit allarch
+inherit setuptools
+inherit pythonnative
+inherit obmc-phosphor-license
+
+PROVIDES += "virtual/obmc-inventory-data"
+RPROVIDES_${PN} += "virtual-obmc-inventory-data"
+
+DEPENDS += "python"
+
+S = "${WORKDIR}"
+SRC_URI += "file://Quanta-q71l.py"
+
+# the following is unnecessary.
+python() {
+	machine = d.getVar('MACHINE', True).capitalize() + '.py'
+	d.setVar('_config_in_skeleton', machine)
+}
+
+do_make_setup() {
+        cp ${S}/${_config_in_skeleton} \
+                ${S}/obmc_system_config.py
+        cat <<EOF > ${S}/setup.py
+from distutils.core import setup
+
+setup(name='${BPN}',
+    version='${PR}',
+    py_modules=['obmc_system_config'],
+    )
+EOF
+}
+
+addtask make_setup after do_patch before do_configure