meta-quanta: gsj: Detect dual rotor fan fail

While rpm of dual rotor are lower than critical threshold
of fan, the script would stop phosphor-pid-control.service
and set other rotors pwm to 255 until fail rotor recover,
which test on gsj board pass.

Signed-off-by: Duke Du <Duke.Du@quantatw.com>
Change-Id: Id8d4b9476d8f6783a9b2cf77b0ff4b82cd985a75
diff --git a/meta-gsj/recipes-gsj/detect-fan-fail/detect-fan-fail.bb b/meta-gsj/recipes-gsj/detect-fan-fail/detect-fan-fail.bb
new file mode 100644
index 0000000..86303c3
--- /dev/null
+++ b/meta-gsj/recipes-gsj/detect-fan-fail/detect-fan-fail.bb
@@ -0,0 +1,26 @@
+SUMMARY = "OpenBMC Quanta Detect Fan Fail Service"
+DESCRIPTION = "OpenBMC Quanta Detect Fan Fail Daemon."
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${QUANTABASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
+
+inherit systemd
+
+DEPENDS += "systemd"
+RDEPENDS_${PN} += "bash"
+
+FILESEXTRAPATHS_append_gsj := "${THISDIR}/files:"
+SRC_URI_append_gsj =  " file://detect-fan-fail.sh \
+                        file://detect-fan-fail.service \
+                      "
+
+do_install_append_gsj() {
+    install -d ${D}${bindir}
+    install -m 0755 ${WORKDIR}/detect-fan-fail.sh ${D}${bindir}/
+
+    install -d ${D}${systemd_unitdir}/system/
+    install -m 0644 ${WORKDIR}/detect-fan-fail.service ${D}${systemd_unitdir}/system
+}
+
+SYSTEMD_PACKAGES = "${PN}"
+SYSTEMD_SERVICE_${PN} = "detect-fan-fail.service"