meta-quanta: gbs: boot status led action

The sys_boot_status LED would be set blinking
until host post done. When host post done, the
action of sys_boot_status would be set on

Note:
1. LED action is set in led.yaml under
   "gbs-led-manager-config" directory
2. sys_boot_status LED gpio is set in kernel dts

Signed-off-by: George Hung <george.hung@quantatw.com>
Change-Id: Ieaa377a74a55afbe9ede670876b2e4a2d03316f2
diff --git a/meta-gbs/recipes-gbs/boot-status-led/gbs-boot-status-led.bb b/meta-gbs/recipes-gbs/boot-status-led/gbs-boot-status-led.bb
new file mode 100644
index 0000000..61c6ed4
--- /dev/null
+++ b/meta-gbs/recipes-gbs/boot-status-led/gbs-boot-status-led.bb
@@ -0,0 +1,25 @@
+SUMMARY = "OpenBMC Quanta Boot Status LED Service"
+DESCRIPTION = "OpenBMC Quanta Boot Status LED Daemon."
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+inherit systemd
+
+DEPENDS += "systemd"
+RDEPENDS_${PN} += "bash"
+
+SRC_URI = " file://boot-status-led.sh \
+            file://boot-status-led.service \
+          "
+
+do_install() {
+    install -d ${D}${bindir}
+    install -m 0755 ${WORKDIR}/boot-status-led.sh ${D}${bindir}/
+
+    install -d ${D}${systemd_system_unitdir}
+    install -m 0644 ${WORKDIR}/boot-status-led.service ${D}${systemd_system_unitdir}
+}
+
+SYSTEMD_PACKAGES = "${PN}"
+SYSTEMD_SERVICE_${PN} = "boot-status-led.service"