meta-quanta: meta-common: enable TLS with static CA and specific user

Add Security Feature:
    1. default-users: Add static User "Megapede"
    2. enable-tls: Enable TLS authentication with static CA
    3. phosphor-monitor-hostname: Generate a self-signed certificate once
       the hostname is assigned

Note:
    1. CA PATH:
       meta-quanta\meta-common\recipes-phosphor\certificate\phosphor-certificate-manager\certs\authority
       All CAs under the folder will be encapsulated into the firmware image

Signed-off-by: AlanKuo <Alan_Kuo@quantatw.com>
Change-Id: Ie1216e1219fafe968363470a84f7b80da27de8c7
diff --git a/meta-common/recipes-quanta/enable-tls/enable-tls.bb b/meta-common/recipes-quanta/enable-tls/enable-tls.bb
new file mode 100644
index 0000000..fca483e
--- /dev/null
+++ b/meta-common/recipes-quanta/enable-tls/enable-tls.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Enable TLS with static CA"
+DESCRIPTION = "Add static CA and only enable TLS authentication"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+SRC_URI += "file://certs/authority/ \
+            file://bmcweb_persistent_data.json \
+           "
+do_install(){
+    install -d ${D}${sysconfdir}/ssl/certs/authority
+    install -m 0644 -D ${WORKDIR}/certs/authority/* \
+                       ${D}${sysconfdir}/ssl/certs/authority
+
+    install -d ${D}${ROOT_HOME}
+    install -m 0640 ${WORKDIR}/bmcweb_persistent_data.json ${D}${ROOT_HOME}
+}
+
+FILES_${PN} = "${ROOT_HOME}/bmcweb_persistent_data.json \
+               ${sysconfdir}/ssl/certs/authority/* \
+              "